BETA

4th June 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [04/06/18 05:23 AM] with 'Partial Outage'

Issue has been resolved at [04/06/18 05:28 AM]