BETA

3rd June 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [03/06/18 05:39 PM] with 'Major Outage'

Issue has been resolved at [03/06/18 05:44 PM]