BETA

14th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/03/19 11:01 AM] with 'Partial Outage'

Issue has been resolved at [14/03/19 11:02 AM]