BETA

2nd June 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [02/06/18 05:53 PM] with 'Major Outage'

Issue has been resolved at [02/06/18 05:55 PM]