BETA

2nd June 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [02/06/18 05:33 PM] with 'Major Outage'

Issue has been resolved at [02/06/18 05:34 PM]