BETA

2nd June 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [02/06/18 03:49 PM] with 'Major Outage'

Issue has been resolved at [02/06/18 04:29 PM]