BETA

1st June 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [01/06/18 05:40 PM] with 'Major Outage'

Issue has been resolved at [01/06/18 05:41 PM]