BETA

1st June 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [01/06/18 12:54 PM] with 'Major Outage'

Issue has been resolved at [01/06/18 12:55 PM]