BETA

1st June 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [01/06/18 12:45 PM] with 'Major Outage'

Issue has been resolved at [01/06/18 01:13 PM]