BETA

31st May 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [31/05/18 09:10 PM] with 'Major Outage'

Issue has been resolved at [31/05/18 09:12 PM]