BETA

27th May 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [27/05/18 06:56 AM] with 'Major Outage'

Issue has been resolved at [27/05/18 07:41 AM]