BETA Singapore cluster       Mumbai cluster

29th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [29/04/19 08:50 PM] with 'Partial Outage'

Issue has been resolved at [29/04/19 08:59 PM]