BETA

24th May 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [24/05/18 08:49 PM] with 'Partial Outage'

Issue has been resolved at [24/05/18 11:42 PM]