BETA

24th May 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [24/05/18 07:29 PM] with 'Major Outage'

Issue has been resolved at [24/05/18 11:42 PM]