BETA

24th May 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [24/05/18 07:29 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [31/05/18 06:28 PM]