BETA

14th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/03/19 10:51 AM] with 'Partial Outage'

Issue has been resolved at [14/03/19 10:53 AM]