BETA

22nd May 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [22/05/18 10:52 AM] with 'Major Outage'

Issue has been resolved at [22/05/18 10:58 AM]