BETA

22nd May 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [22/05/18 10:41 AM] with 'Major Outage'

Issue has been resolved at [22/05/18 10:42 AM]