BETA

29th April 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [29/04/19 08:13 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [29/04/19 08:21 PM]