BETA

20th May 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [20/05/18 10:42 AM] with 'Major Outage'

Issue has been resolved at [20/05/18 10:43 AM]