BETA

29th April 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [29/04/19 08:07 PM] with 'Partial Outage'

Issue has been resolved at [29/04/19 08:09 PM]