BETA

18th May 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [18/05/18 09:59 PM] with 'Major Outage'

Issue has been resolved at [18/05/18 10:18 PM]