BETA

18th May 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [18/05/18 09:40 PM] with 'Major Outage'

Issue has been resolved at [18/05/18 11:39 PM]