BETA

29th April 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/04/19 08:01 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [29/04/19 08:05 PM]