BETA

15th May 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [15/05/18 04:32 AM] with 'Major Outage'

Issue has been resolved at [15/05/18 04:35 AM]