BETA

11th May 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/05/18 11:22 PM] with 'Partial Outage'

Issue has been resolved at [11/05/18 11:24 PM]