BETA

11th May 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [11/05/18 02:21 AM] with 'Major Outage'

Issue has been resolved at [11/05/18 02:22 AM]