BETA

10th May 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [10/05/18 05:10 PM] with 'Major Outage'

Issue has been resolved at [10/05/18 05:13 PM]