BETA

10th May 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [10/05/18 12:11 PM] with 'Major Outage'

Issue has been resolved at [10/05/18 12:13 PM]