BETA

5th April 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [05/04/17 05:22 PM] with 'Partial Outage'

Issue has been resolved at [05/04/17 05:23 PM]