BETA

9th May 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [09/05/18 11:07 AM] with 'Major Outage'

Issue has been resolved at [09/05/18 01:07 PM]