BETA

9th May 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [09/05/18 11:07 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [09/05/18 01:07 PM]