BETA

8th May 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [08/05/18 10:16 AM] with 'Major Outage'

Issue has been resolved at [08/05/18 10:17 AM]