BETA

8th May 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [08/05/18 03:42 AM] with 'Major Outage'

Issue has been resolved at [08/05/18 03:44 AM]