BETA

8th May 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [08/05/18 03:38 AM] with 'Major Outage'

Issue has been resolved at [08/05/18 03:39 AM]