BETA

8th May 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [08/05/18 03:38 AM] with 'Major Outage'

Issue has been resolved at [08/05/18 03:39 AM]