BETA

8th May 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [08/05/18 03:21 AM] with 'Major Outage'

Issue has been resolved at [08/05/18 03:23 AM]