BETA

29th April 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/04/19 06:55 PM] with 'Partial Outage'

Issue has been resolved at [29/04/19 07:15 PM]