BETA

8th May 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [08/05/18 12:49 AM] with 'Partial Outage'

Issue has been resolved at [08/05/18 12:51 AM]