BETA

5th May 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [05/05/18 01:56 PM] with 'Major Outage'

Issue has been resolved at [05/05/18 01:57 PM]