BETA

5th May 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [05/05/18 07:47 AM] with 'Major Outage'

Issue has been resolved at [05/05/18 07:48 AM]