BETA

5th May 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [05/05/18 01:41 AM] with 'Major Outage'

Issue has been resolved at [05/05/18 01:45 AM]