BETA

29th April 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [29/04/19 06:32 PM] with 'Partial Outage'

Issue has been resolved at [29/04/19 06:34 PM]