BETA

4th May 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [04/05/18 01:41 PM] with 'Major Outage'

Issue has been resolved at [04/05/18 01:47 PM]