BETA

3rd May 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [03/05/18 12:41 PM] with 'Major Outage'

Issue has been resolved at [03/05/18 12:43 PM]