BETA

3rd May 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [03/05/18 09:26 AM] with 'Major Outage'

Issue has been resolved at [03/05/18 09:27 AM]