BETA

2nd May 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [02/05/18 09:08 PM] with 'Major Outage'

Issue has been resolved at [02/05/18 09:10 PM]