BETA

28th April 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [28/04/18 02:59 PM] with 'Major Outage'

Issue has been resolved at [28/04/18 03:00 PM]