BETA

28th April 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [28/04/18 01:53 PM] with 'Major Outage'

Issue has been resolved at [28/04/18 01:54 PM]