BETA

14th March 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [14/03/19 09:05 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/03/19 09:08 AM]